Batty’s Coordinates Plus Mod for MC 1.14.4 / 1.13.2 / 1.12.2

Diverse information on screen, without having to consult “F3”.

Batty’s Coordinates Plus 1.14.4 is a mod that will allow us to display, in a discrete way, information such as X, Y, and Z coordinates, which are consulted by default after pressing the “F3” key, in addition to adding another type of information useful for players, when and how each of them wants or needs.

Batty’s Coordinates Plus Mod
Batty’s Coordinates Plus Mod

This mod adds various informative modules to the game screen. We can consulate the coordinates, the time of day, a numerical time counter, as well as the biome in which we are. This, and another, information will appear discreetly and permanently on the screen. Players will be able to locate this information in several areas of the screen.

Screen Location
Screen Location
Batty's Coordinates Mod PLUS for Forge
Batty’s Coordinates Mod PLUS for Forge

This mod is in Alpha update phase, so it may still contain errors or bugs. We will publish your respective updates in this same article.

How to Install Minecraft Batty’s Coordinates Plus Mod ?

  1. Download and Install Minecraft Forge
  2. Download Minecraft Batty’s Coordinates Plus Mod
  3. Double-click on the file downloaded from Forge to run the installer.
  4. Unzip the downloaded file from the mod.
  5. Paste the downloaded file the folder .minecraft/mods
  6. We have it installed and ready to offer information on the screen!

Download Batty’s Coordinates Plus Mod for Minecraft

for MC 1.14.4 ⇒ Download

for MC 1.14.3 ⇒ Download

for MC 1.13.2 ⇒ Download

for MC 1.12.2 ⇒ Download

for MC 1.11.2 ⇒ Download

for MC 1.10.2 ⇒ Download

for MC 1.7.10 ⇒ Download

Credit: BatHeart | Source: CurseForge

3 Comments
  1. Vloop says

    Hi!
    Nice post, but the download links take us to this same page here, not to Batty’s download.
    =(

    1. BlockMinecraft says

      Hi, Links edited.

  2. Baldazar says

    After downloading forge 1.14 and then this mod I get a message that the mod is for an older version of forge (1.12) and cannot be loaded. How do I fix this?

Leave A Reply

Your email address will not be published.

This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. Accept Read More

Privacy & Cookies Policy